Обновляюсь до Ubuntu 14.04 LTS и проблемы с CUPS

В этот раз ubuntu 12.04 LTS работал безупречно и радовал меня каждый день. Что мотивировало к обновлению? Ответ не простой.

Иногда, нам приходится что-то менять в своей жизни под действием внешних обстоятельств. Часто случается так, что возникает желание, что-нибудь изменить в своей жизни без явных причин. Мне интересно, в чем заключается различие между двумя изменениями? В данном посте, у автора не готов окончательный ответ на поставленнй вопрос, но он часто думает о нем. ))

На сегодняшний день, после установки всех обновлений я получил:

sergey@rskl:~$ uname -a
Linux rskl 3.13.0-37-generic #64-Ubuntu SMP Mon Sep 22 21:28:38 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux


В сети очень много сведений, чем богат 14.04, но все они ограничиваются обзором графической оболочки Unity, которой я не пользуюсь. Но мой любимый gnome-shell тоже обновился:

sergey@rskl:~$ gnome-shell --version
GNOME Shell 3.10.4

Он стал еще минималистичнее. Я старался, но не смог найти ничего лишнего. Нет никаких навязчивых апплетов, онлайн-сервисов и прочих раздражающих рюшек. Да, я искал тебя много лет, а когда потерял всякую надежду… Так, так… о чем это я? Похоже меня снова тянет к вопросу, поставленному в начеле поста. )) Нижняя панель уведомлений теперь скрыта и появляется только при наведении курсора в правый нижний угол экрана.

Что нового в ядре можно посмотреть на любимом opennet.ru

Самые бросающиеся красноглазому взору линуксоида новшевства, касаюся всяческих улучшений для SSD-накопителей и включение по умолчанию режима TCP Fast Open, который очень полюбился google.

Теперь о траблах. После обновления система выдала несколько системных ошибок. После нескольких подходов установки всех обновлений через стандартную обновлялку «Обновление приложений» и трех перезагрузок, как обычно, большая их часть рассосалась. Рассосалась куда-то и подсистема печати CUPS. Демон не стартовал, было принято решение переустановить полностью все, что его касалось.

sudo apt-get purge cups
sudo apt-get install cups

Все, так и должно быть, получаем удар прямо в сердце, когда пытаемся выходить за рамки дозволенного. Похожее произошло и в этот раз:

E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты?

Попытки с чисткой кэша apt и двухчасовой танец красноглазого дьявола вокруг менеджера пакетов не увенчались успехом. Пришлось собирать cups из исходников. Для тех, кто столкнулся с похожей бедой, я починил все так:

1. Получил с http://www.cups.org/software.php архив cups-1.7.5-source.tar.bz2
2. После распаковки архива выполнил волшебные:

./configure
make
sudo make install

3. Запустил «Настройка принтера», установил принтер.

Был удивлен, что так «безгеморойно» все прошло… бывает же… вот бы и в жизни так.

2 Comments

  1. Dinosaur:

    Некоторые до сих пор на цапле сидят (8.04) — и ничего, всё работает. Хотя на неё дрова принтера компилировались тоже в своё время. А нынче бубен запылился что-то ))

  2. admin:

    Ранее, никогда не обновлялся без явной надобности. ) Впрочем, даже этот свой поступок я смог понять, в отличие от остальных…

Leave a Reply to admin

*